Import: Agilent MassHunter

Command: File > Import Data > Agilent MassHunter

The Agilent MassHunter import filter is an import filter which supports laser ablation instruments based on Agilent mass spectrometers and the MassHunter software of Agilent. For importing your data to , you have first to export the individual scan lines of your image as a .csv (comma separated values) file. All the scan line files have to be stored in an empty directory and have to be numbered according to the scan line index.

In order to be able to assign the individual scan line files to the corresponding line in the final image, uses a file mask template which specifies where the scan line number is encoded. For example, if the exported scan line files are named "scanl_000.csv" (with "000" being the scan line index) then the file mask should be "scanl_#.csv". The hash character (#) indicates the position of the index number. Please note that if there are blanks in the file names you have to provide for the blanks by including the blanks in the mask as well.

If you are sampling the ablated material at fixed time intervals you might want to resample your data by a factor which reflects the measured data samples per laser spot. If you do not resample the data, the resulting image will most probably exhibit an unfavourable aspect ratio (with the x axis being much longer than the y axis). In addition, by resampling the measured data noise is also reduced, since the resulting pixels are the averages of N data samples (N being the resampling factor). A simple trick to set a suitable resampling factor is to look at the final image size, which of course, should reflect the number of actual laser spots per line.

How To:
  1. Click the command "File>Import Data>Agilent MassHunter"
  2. Click the button "Select Data Files" and select one of the line scan files to be imported.
  3. Select the elements you want to import. By default, all elements are selected.
  4. Enter and/or edit the name of the sample and its description.
  5. Select an appropriate resampling factor
  6. Click the "Import Data" button



(1) If you have a similar instrumental setup and you need to import your image data, please contact Epina. In many cases we can help you to get your data into .