Exporting ENVI Data

Command: File > Export Data > Raw Data > ENVI Format

ImageLab supports the export of the image data in ENVI format. You have to select the range of data to be exported (x, y, and time coordinates). If the data cube contains more than one spectral group you have to select it as well (the ENVI format supports only one kind of spectral data per file).

Further, the options for the byte order and the interleave mode allows to create ENVI files in a form that it can be read by other software. Unless the software which will be used to read the generated ENVI file does not fully support the ENVI format you need not take care of these parameters.

If you decide not to export masked pixels the spectral values of these pixels will be replaced by constant values (ENVI does not support missing pixels or pixel masks, thus the masked pixels are replaced by a fixed value specified in the preferences, see "Substitute for Indefinite Values").

How To:
  1. Click the command File>Export Data>Raw Data>ENVI Format
  2. Set the data range to be exported
  3. If more than one spectral group is available, select the spectral group
  4. Optionally select a pixel mask to exclude certain pixels from being exported
  5. Select the ENVI format parameters (Byte Order and Interleave)
  6. Click the "Export Data" button


Last Update: 2020-Jan-04